about summary refs log tree commit diff
path: root/modules/services/matrix-bridge.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2024-01-14 12:37:14 +0900
committersefidel <contact@sefidel.net>2024-01-14 12:37:14 +0900
commit813a4f4340849b407eaa9d03f65fbe8f3e716bf2 (patch)
tree6af83c5bdc887accc01e1f3ed4f6e1a53d7d8d0b /modules/services/matrix-bridge.nix
parent38b45cd6d6caffb6c32ed8720b3174f25354f965 (diff)
downloadinfra-813a4f4340849b407eaa9d03f65fbe8f3e716bf2.tar.gz
infra-813a4f4340849b407eaa9d03f65fbe8f3e716bf2.zip
feat(modules): use types.path for secret paths
Diffstat (limited to 'modules/services/matrix-bridge.nix')
-rw-r--r--modules/services/matrix-bridge.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/services/matrix-bridge.nix b/modules/services/matrix-bridge.nix
index a9d3c4f..3e86706 100644
--- a/modules/services/matrix-bridge.nix
+++ b/modules/services/matrix-bridge.nix
@@ -14,7 +14,7 @@ in
     enable = mkEnableOption "matrix-bridge";
     domain = mkOption { type = types.str; };
     realHost = mkOption { type = types.str; default = "matrix.${cfg.domain}"; };
-    secrets.mautrix-envs = mkOption { type = types.str; description = "path to the mautrix-* environment file"; };
+    secrets.mautrix-envs = mkOption { type = types.path; description = "path to the mautrix-* environment file"; };
   };
 
   config = mkIf cfg.enable {