about summary refs log tree commit diff
path: root/modules/services/nixos-mailserver.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/nixos-mailserver.nix')
-rw-r--r--modules/services/nixos-mailserver.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/modules/services/nixos-mailserver.nix b/modules/services/nixos-mailserver.nix
index 7a8c5a5..59571bc 100644
--- a/modules/services/nixos-mailserver.nix
+++ b/modules/services/nixos-mailserver.nix
@@ -17,6 +17,11 @@ in
       owner = "dovecot2";
       group = "dovecot2";
     };
+    sops.secrets.system-imap-pass = {
+      mode = "0440";
+      owner = "dovecot2";
+      group = "dovecot2";
+    };
     sops.secrets.internal-imap-pass = {
       mode = "0440";
       owner = "dovecot2";
@@ -84,7 +89,11 @@ in
           hashedPasswordFile = config.sops.secrets.sefidel-imap-pass.path;
         };
         "system@exotic.sh" = {
-          aliases = [ "system@nand.moe" ];
+          aliases = [ "system" "system@nand.moe" ];
+          hashedPasswordFile = config.sops.secrets.system-imap-pass.path;
+        };
+        "internal@exotic.sh" = {
+          aliases = [ "internal" ];
           hashedPasswordFile = config.sops.secrets.internal-imap-pass.path;
         };
       };