about summary refs log tree commit diff
path: root/systems/cobalt/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'systems/cobalt/default.nix')
-rw-r--r--systems/cobalt/default.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/systems/cobalt/default.nix b/systems/cobalt/default.nix
index 135017c..2210f25 100644
--- a/systems/cobalt/default.nix
+++ b/systems/cobalt/default.nix
@@ -164,6 +164,7 @@ in
   # sops.secrets.openldap-admin-key = {
   # owner = "openldap";
   # };
+  sops.secrets.searx-env = { };
 
   nix.experimentalFeatures = "nix-command flakes";
 
@@ -298,7 +299,12 @@ in
       domain = "exotic.sh";
       realHost = "todo.exotic.sh";
     };
-
+    services.searx = {
+      enable = false;
+      domain = "exotic.sh";
+      realHost = "searx.labs.exotic.sh";
+      secrets.searx-env = config.sops.secrets.searx-env.path;
+    };
 
     services.nixos-mailserver.enable = true; # TODO: replace with dovecot.nix?