about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index 48147e6..9cb3aa9 100644
--- a/flake.nix
+++ b/flake.nix
@@ -31,7 +31,11 @@
     nix-gaming.inputs.nixpkgs.follows = "unstable";
   };
 
-  outputs = { self, ... } @ inputs:
+  outputs = { self, unstable, ... } @ inputs:
+  let
+    lib = unstable.lib.extend
+      (self: super: { my = import ./lib { inherit inputs; lib = self; }; });
+  in
     {
       nixosConfigurations = import ./nixos inputs;
 
@@ -40,8 +44,6 @@
       packages.x86_64-linux = self.lib.nixosConfigurationsAsPackages.x86_64-linux
         // self.lib.homeConfigurationsAsPackages.x86_64-linux;
 
-      checks = self.packages;
-
-      lib = import ./lib inputs;
+      lib = lib.my;
     };
 }