about summary refs log tree commit diff
path: root/home/modules/profiles/base/config/sway.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/modules/profiles/base/config/sway.nix')
-rw-r--r--home/modules/profiles/base/config/sway.nix38
1 files changed, 20 insertions, 18 deletions
diff --git a/home/modules/profiles/base/config/sway.nix b/home/modules/profiles/base/config/sway.nix
index ead4bfe..f294af5 100644
--- a/home/modules/profiles/base/config/sway.nix
+++ b/home/modules/profiles/base/config/sway.nix
@@ -1,4 +1,6 @@
-{ pkgs, wallpapers }:
+{ pkgs, neotheme }:
+
+with neotheme.palette.colors;
 
 ''
   exec autotiling
@@ -157,22 +159,22 @@
   gaps inner 8
   smart_borders on
 
-  set $color0 #18191f
-  set $color1 #e27878
-  set $color2 #b4be82
-  set $color3 #e2a478
-  set $color4 #84a0c6
-  set $color5 #a093c7
-  set $color6 #89b8c2
-  set $color7 #c6c8d1
-  set $color8 #3c3d43
-  set $color9 #e98989
-  set $color10 #c0ca8e
-  set $color11 #e9b189
-  set $color12 #91acd1
-  set $color13 #ada0d3
-  set $color14 #95c4ce
-  set $color15 #d2d4de
+  set $color0 #${color0}
+  set $color1 #${color1}
+  set $color2 #${color2}
+  set $color3 #${color3}
+  set $color4 #${color4}
+  set $color5 #${color5}
+  set $color6 #${color6}
+  set $color7 #${color7}
+  set $color8 #${bright0}
+  set $color9 #${bright1}
+  set $color10 #${bright2}
+  set $color11 #${bright3}
+  set $color12 #${bright4}
+  set $color13 #${bright5}
+  set $color14 #${bright6}
+  set $color15 #${bright7}
 
   set $primary $color4
   set $muted #4d698f
@@ -182,7 +184,7 @@
   client.focused_inactive $muted $muted $color0 $color5
   client.unfocused        $muted $muted $color7 $color5
   client.urgent           $color10 $color10 $color0 $color5
-  output "*" bg ${wallpapers}/nixos/nix-glow-fg-d4ae80.png fill
+  output "*" bg ${neotheme.wallpaper} fill
   output "*" scale 1
   output "*" scale_filter nearest