about summary refs log tree commit diff
path: root/home/modules/profiles/base/config/waybar-style.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/modules/profiles/base/config/waybar-style.nix')
-rw-r--r--home/modules/profiles/base/config/waybar-style.nix24
1 files changed, 14 insertions, 10 deletions
diff --git a/home/modules/profiles/base/config/waybar-style.nix b/home/modules/profiles/base/config/waybar-style.nix
index ccb88b2..c47ea23 100644
--- a/home/modules/profiles/base/config/waybar-style.nix
+++ b/home/modules/profiles/base/config/waybar-style.nix
@@ -1,3 +1,7 @@
+{ neotheme }:
+
+with neotheme.palette.colors;
+
 ''
   * {
     border: none;
@@ -8,20 +12,20 @@
   }
 
   window#waybar {
-    background: #18191f;
-    color: #84a0c6;
+    background: #${background};
+    color: #${foreground};
   }
 
   #workspaces button {
     padding: 0 8px;
-    background: #84a0c6;
-    color: #18191f;
+    background: #${color4};
+    color: #${background};
     border-bottom: 3px solid rgba (255, 255, 255, .2);
   }
 
   #workspaces button.focused {
-    background-color: #84a0c6;
-    border-bottom: 3px solid #18191f;
+    background-color: #${color4};
+    border-bottom: 3px solid #${background};
   }
 
   #workspaces button:hover {
@@ -43,15 +47,15 @@
   #custom-weather {
     padding: 0 10px;
     margin: 0 4px;
-    color: #18191f;
-    background-color: #84a0c6;
+    color: #${background};
+    background-color: #${color4};
     border-bottom: 3px solid rgba (255, 255, 255, .2);
   }
 
   @keyframes blink {
     to {
-      background-color: #84a0c6;
-      color: #18191f;
+      background-color: #${color4};
+      color: #${background};
     }
   }
 ''