about summary refs log tree commit diff
path: root/home/modules/profiles/base/config/waybar-style.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/modules/profiles/base/config/waybar-style.nix')
-rw-r--r--home/modules/profiles/base/config/waybar-style.nix67
1 files changed, 13 insertions, 54 deletions
diff --git a/home/modules/profiles/base/config/waybar-style.nix b/home/modules/profiles/base/config/waybar-style.nix
index af22330..ae9041e 100644
--- a/home/modules/profiles/base/config/waybar-style.nix
+++ b/home/modules/profiles/base/config/waybar-style.nix
@@ -16,17 +16,21 @@
     padding: 0 4px;
     background: #84a0c6;
     color: #18191f;
-    border-bottom: 2px solid #84a0c6;
+    border-bottom: 3px solid rgba (255, 255, 255, .2);
   }
 
   #workspaces button.focused {
-    background: #84a0c6;
-    border-bottom: 2px solid #18191f;
+    background-color: #84a0c6;
+    border-bottom: 3px solid #18191f;
+  }
+
+  #workspaces button:hover {
+    box-shadow: inherit;
+    text-shadow: inherit;
   }
 
   #clock,
   #cpu,
-  #battery,
   #temperature,
   #backlight,
   #network,
@@ -36,12 +40,12 @@
   #tray,
   #mode,
   #mpd,
-  #custom-weather,
-  #custom-nixos {
-    padding: 0 6px;
-    margin: 0;
-    background-color: #84a0c6;
+  #custom-weather {
+    padding: 0 10px;
+    margin: 0 4px;
     color: #18191f;
+    background-color: #84a0c6;
+    border-bottom: 3px solid rgba (255, 255, 255, .2);
   }
 
   @keyframes blink {
@@ -50,49 +54,4 @@
       color: #18191f;
     }
   }
-
-  #cpu {
-    background-color: #a093c7;
-  }
-
-  #network {
-    background-color: #a093c7;
-  }
-
-  #memory {
-    background-color: #a093c7;
-  }
-
-  #pulseaudio {
-    background-color: #a093c7;
-  }
-
-  #battery {
-    background-color: #a093c7;
-  }
-
-  #battery.full {
-    background-color: #a093c7;
-    color: #18191f;
-  }
-
-  #battery.discharging {
-    background-color: #a093c7;
-    color: #18191f;
-  }
-
-  #battery.charging {
-    background-color: #a093c7;
-    color: #18191f;
-  }
-
-  #battery.warning:not(.charging) {
-    background-color: #a093c7;
-    color: #18191f;
-    animation-name: blink;
-    animation-duration: 0.5s;
-    animation-timing-function: linear;
-    animation-iteration-count: infinite;
-    animation-direction: alternate;
-  }
 ''