about summary refs log tree commit diff
path: root/home/profiles/base-darwin/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/base-darwin/default.nix')
-rw-r--r--home/profiles/base-darwin/default.nix172
1 files changed, 0 insertions, 172 deletions
diff --git a/home/profiles/base-darwin/default.nix b/home/profiles/base-darwin/default.nix
deleted file mode 100644
index ea334a8..0000000
--- a/home/profiles/base-darwin/default.nix
+++ /dev/null
@@ -1,172 +0,0 @@
-{ config, lib, inputs, pkgs, self, ... }:
-let
-  cfg = config.profiles.base-darwin;
-in
-{
-  imports = [
-    ../../modules/programs/nixpkgs
-    ../../modules/programs/zshell
-  ];
-
-  options.profiles.base-darwin.enable = lib.mkEnableOption
-    "The base profile, contains general configurations. (Darwin)";
-
-  config = lib.mkIf cfg.enable {
-    home.sessionVariables = rec {
-      # NIXOS_OZONE_WL = 1; # FIXME: interface 'wl_output' has no event 4
-      EDITOR = "nvim";
-      VISUAL = "nvim";
-      GIT_EDITOR = EDITOR;
-    };
-
-    home.packages = [
-      # Nix Tools
-      pkgs.nix-index
-      pkgs.nix-tree
-      pkgs.nix-top
-      pkgs.nix-update
-      pkgs.hydra-check
-
-      pkgs.aria2
-      pkgs.bottom
-      pkgs.croc
-      pkgs.fd
-      pkgs.fzf
-      pkgs.iterm2
-      pkgs.libnotify
-      pkgs.procs
-      pkgs.sops
-      pkgs.tree
-      pkgs.pinentry_mac
-
-      pkgs.neovim
-      pkgs.nodejs
-
-      # Common build tools
-      (pkgs.rust-bin.selectLatestNightlyWith (toolchain: toolchain.default.override { extensions = [ "rust-src" ]; }))
-      pkgs.go
-
-      (pkgs.writeShellScriptBin "0x0" (import ./scripts/0x0.nix))
-    ];
-
-    programs = {
-      direnv.enable = true;
-      direnv.nix-direnv.enable = true;
-      exa.enable = true;
-      exa.enableAliases = true;
-      gpg.enable = true;
-      gpg.settings.keyserver = "keys.openpgp.org";
-      home-manager.enable = true;
-      htop.enable = true;
-
-      tmux = {
-        enable = true;
-
-        prefix = "C-f";
-        terminal = "xterm-256color";
-        shell = "${pkgs.zsh}/bin/zsh";
-        baseIndex = 1;
-        keyMode = "vi";
-
-        escapeTime = 0;
-
-        extraConfig = import ./config/tmux.nix;
-
-      };
-      zsh = {
-        enable = true;
-
-        enableCompletion = true;
-        enableAutosuggestions = true;
-
-        autocd = true;
-
-        dotDir = ".config/zsh";
-
-        plugins = [
-          {
-            name = "powerlevel10k";
-            src = pkgs.zsh-powerlevel10k;
-            file = "share/zsh-powerlevel10k/powerlevel10k.zsh-theme";
-          }
-
-          {
-            name = "powerlevel10k-config";
-            src = lib.cleanSource ./p10k-config;
-            file = "p10k.zsh";
-          }
-
-          {
-            name = "zsh-syntax-highlighting";
-            src = pkgs.fetchFromGitHub {
-              owner = "zsh-users";
-              repo = "zsh-syntax-highlighting";
-              rev = "0.7.1";
-              sha256 = "03r6hpb5fy4yaakqm3lbf4xcvd408r44jgpv4lnzl9asp4sb9qc0";
-            };
-          }
-          {
-            name = "zsh-sudo";
-            src = pkgs.fetchFromGitHub {
-              owner = "none9632";
-              repo = "zsh-sudo";
-              rev = "33d81184e2998b8484b494e77c8e35f74b8580ff";
-              sha256 = "sha256-2ZQJMNaPTtx/kIvs5TF/ojiecNT8jaZvSzoVAFXmxgQ=";
-            };
-          }
-        ];
-
-        shellAliases = config.programs.zshell.aliases;
-        initExtra = import ./config/zsh.nix;
-      };
-
-      zshell.aliases = {
-        e = "nvim";
-        nvimdiff = "nvim -d";
-        clear = "clear && printf '\\e[3J'";
-      };
-
-      zoxide = {
-        enable = true;
-        enableZshIntegration = true;
-      };
-
-      # TODO: https://github.com/zellij-org/zellij/issues/1013
-      # zellij = {
-      #   enable = true;
-      #
-      #   settings = {
-      #     default_mode = "normal";
-      #     pane_frames = false;
-      #     simplified_ui = true; # bitmap fonts
-      #
-      #     themes = {
-      #       default = {
-      #         # Industrial Jellybeans theme
-      #         bg = [ 21 21 21 ];
-      #         fg = [ 136 136 136 ];
-      #         black = [ 28 28 28 ];
-      #         gray = [ 64 64 64 ];
-      #         white = [ 232 232 211 ];
-      #         red = [ 141 61 38 ];
-      #         orange = [ 250 187 110 ];
-      #         yellow = [ 250 208 122 ];
-      #         green = [ 153 173 106 ];
-      #         blue = [ 129 151 191 ];
-      #         cyan = [ 143 191 220 ];
-      #         magenta = [ 198 182 238 ];
-      #       };
-      #     };
-      #   };
-      # };
-    };
-
-    home.file."${config.programs.gpg.homedir}/gpg-agent.conf".text = ''
-      default-cache-ttl 3600
-      default-cache-ttl-ssh 3600
-      pinentry-program ${pkgs.pinentry_mac}/Applications/pinentry-mac.app/Contents/MacOS/pinentry-mac
-      allow-preset-passphrase
-      enable-ssh-support
-    '';
-  };
-}