about summary refs log tree commit diff
path: root/home/profiles/base/config/waybar/settings.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/base/config/waybar/settings.nix')
-rw-r--r--home/profiles/base/config/waybar/settings.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/home/profiles/base/config/waybar/settings.nix b/home/profiles/base/config/waybar/settings.nix
index 07bf8a9..70ae97e 100644
--- a/home/profiles/base/config/waybar/settings.nix
+++ b/home/profiles/base/config/waybar/settings.nix
@@ -5,7 +5,7 @@ with neotheme.colors;
   layer = "bottom";
   position = "top";
   height = 22;
-  modules-left = [ "pulseaudio" "custom/separator" "cpu" "custom/separator" "memory" ];
+  modules-left = [ "pulseaudio" "custom/separator" "cpu" "custom/separator" "memory" "custom/separator" "idle_inhibitor" ];
   modules-center = [ "sway/workspaces" ];
   modules-right = [ "battery" "custom/separator" "clock" ];
 
@@ -52,6 +52,10 @@ with neotheme.colors;
     format-alt = "<span foreground='#${color6}'>PWR</span> {power}Wh";
   };
 
+  "idle_inhibitor" = {
+    format = "<span foreground='#${color6}'>CAFFEINE</span> {status}";
+  };
+
   "custom/separator" = {
     format = "|";
     interval = "once";