about summary refs log tree commit diff
path: root/home/profiles/base/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/base/default.nix')
-rw-r--r--home/profiles/base/default.nix55
1 files changed, 27 insertions, 28 deletions
diff --git a/home/profiles/base/default.nix b/home/profiles/base/default.nix
index 754801b..f042f8e 100644
--- a/home/profiles/base/default.nix
+++ b/home/profiles/base/default.nix
@@ -194,34 +194,33 @@ in
         enableZshIntegration = true;
       };
 
-      # TODO: https://github.com/NixOS/nixpkgs/issues/198655
-      # zellij = {
-      #   enable = true;
-      #
-      #   settings = {
-      #     default_mode = "normal";
-      #     pane_frames = false;
-      #     simplified_ui = true; # bitmap fonts
-      #
-      #     themes = {
-      #       default = {
-      #         # Industrial Jellybeans theme
-      #         bg = [ 21 21 21 ];
-      #         fg = [ 136 136 136 ];
-      #         black = [ 28 28 28 ];
-      #         gray = [ 64 64 64 ];
-      #         white = [ 232 232 211 ];
-      #         red = [ 141 61 38 ];
-      #         orange = [ 250 187 110 ];
-      #         yellow = [ 250 208 122 ];
-      #         green = [ 153 173 106 ];
-      #         blue = [ 129 151 191 ];
-      #         cyan = [ 143 191 220 ];
-      #         magenta = [ 198 182 238 ];
-      #       };
-      #     };
-      #   };
-      # };
+      zellij = {
+        enable = true;
+
+        settings = {
+          default_mode = "normal";
+          pane_frames = false;
+          simplified_ui = true; # bitmap fonts
+
+          themes = {
+            default = {
+              # Industrial Jellybeans theme
+              bg = [ 21 21 21 ];
+              fg = [ 136 136 136 ];
+              black = [ 28 28 28 ];
+              gray = [ 64 64 64 ];
+              white = [ 232 232 211 ];
+              red = [ 141 61 38 ];
+              orange = [ 250 187 110 ];
+              yellow = [ 250 208 122 ];
+              green = [ 153 173 106 ];
+              blue = [ 129 151 191 ];
+              cyan = [ 143 191 220 ];
+              magenta = [ 198 182 238 ];
+            };
+          };
+        };
+      };
     };
 
     services = {