about summary refs log tree commit diff
path: root/home/profiles/browsing/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/browsing/default.nix')
-rw-r--r--home/profiles/browsing/default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/home/profiles/browsing/default.nix b/home/profiles/browsing/default.nix
index ab5470c..b6478a5 100644
--- a/home/profiles/browsing/default.nix
+++ b/home/profiles/browsing/default.nix
@@ -8,7 +8,10 @@ in
   };
 
   config = lib.mkIf cfg.enable {
-    home.packages = with pkgs; [ lynx firefox ];
+    home.packages = with pkgs; [ lynx ] ++ pkgs.lib.optionals (pkgs.stdenv.isLinux) [
+      # TODO: currently broken/doesn't support Darwin
+      pkgs.firefox
+    ];
 
     programs.qutebrowser = {
       enable = true;