about summary refs log tree commit diff
path: root/home/profiles/browsing/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/browsing/default.nix')
-rw-r--r--home/profiles/browsing/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/home/profiles/browsing/default.nix b/home/profiles/browsing/default.nix
new file mode 100644
index 0000000..86f3cc1
--- /dev/null
+++ b/home/profiles/browsing/default.nix
@@ -0,0 +1,30 @@
+{ config, lib, pkgs, ... }:
+let cfg = config.profiles.browsing;
+in
+{
+  options.profiles.browsing = {
+    enable = lib.mkEnableOption
+      "A profile that enables a browser for the GUI and the terminal";
+  };
+
+  config = lib.mkIf cfg.enable {
+    home.packages = with pkgs; [ lynx ];
+
+    programs.qutebrowser = {
+      enable = true;
+
+      searchEngines = {
+        g = "https://www.google.com/search?hl=en&q={}";
+        nw = "https://nixos.wiki/index.php?search={}";
+        ns = "https://search.nixos.org/options?channel=unstable&from=0size=50&sort=relevance&type=packages&query={}";
+      };
+
+      quickmarks = {
+        github = "https://github.com";
+        sourcehut = "https://sr.ht";
+      };
+
+      settings = import ./qutebrowser-settings.nix;
+    };
+  };
+}