about summary refs log tree commit diff
path: root/home/profiles/gui/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/gui/default.nix')
-rw-r--r--home/profiles/gui/default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/home/profiles/gui/default.nix b/home/profiles/gui/default.nix
index 32a6d47..9d19a2c 100644
--- a/home/profiles/gui/default.nix
+++ b/home/profiles/gui/default.nix
@@ -124,13 +124,17 @@ in
           { event = "lock"; command = "${pkgs.swaylock-effects}/bin/swaylock -fFc ${neotheme.colors.background} --indicator --grace 2 --fade-in 0.2"; }
         ];
         timeouts = [
+          # 4m30s
           { timeout = 270; command = "${pkgs.libnotify}/bin/notify-send -t 30000 'Locking screen in 30 seconds'"; }
+          # 5m
           { timeout = 300; command = "${pkgs.swaylock-effects}/bin/swaylock -fFc ${neotheme.colors.background} --indicator --grace 2 --fade-in 0.2"; }
+          # 10m
           {
             timeout = 600;
             command = "${pkgs.sway}/bin/swaymsg 'output * dpms off'";
             resumeCommand = "${pkgs.sway}/bin/swaymsg 'output * dpms on'";
           }
+          # 15m
           {
             timeout = 900;
             command = "${pkgs.systemd}/bin/systemctl suspend";