about summary refs log tree commit diff
path: root/home/profiles/messaging/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/profiles/messaging/default.nix')
-rw-r--r--home/profiles/messaging/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/home/profiles/messaging/default.nix b/home/profiles/messaging/default.nix
new file mode 100644
index 0000000..a25f4e1
--- /dev/null
+++ b/home/profiles/messaging/default.nix
@@ -0,0 +1,17 @@
+{ config, lib, pkgs, ... }:
+let cfg = config.profiles.messaging;
+in
+{
+  imports = [ ../../modules/programs/nixpkgs ];
+  
+  options.profiles.messaging = {
+    enable = lib.mkEnableOption
+      "A profile that enables the system to communicate via internet.";
+  };
+
+  config = lib.mkIf cfg.enable {
+    home.packages = with pkgs; [ discord-canary aerc weechat element slack ];
+    
+    nixpkgs.allowedUnfree = [ "discord-canary" "slack" ];
+  };
+}