about summary refs log tree commit diff
path: root/modules/keyd-qol.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/keyd-qol.nix')
-rw-r--r--modules/keyd-qol.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/modules/keyd-qol.nix b/modules/keyd-qol.nix
new file mode 100644
index 0000000..e163286
--- /dev/null
+++ b/modules/keyd-qol.nix
@@ -0,0 +1,36 @@
+{ config, pkgs, unstable, unstable-small, nixpkgs-2211, lib, ... }:
+
+{
+  options.services.keyd-qol.enable = lib.mkEnableOption "keyd service for quality-of-life improvements";
+
+  config = lib.mkIf config.services.keyd-qol.enable {
+    services.keyd.enable = true;
+
+    services.keyd.keyboards = {
+      default = {
+        ids = [ "*" ];
+        settings = {
+          main = {
+            capslock = "overload(control, esc)";
+
+            insert = "S-insert";
+          };
+        };
+      };
+
+      sun = {
+        ids = [
+          # HHKB Hybrid
+          "04fe:0021"
+        ];
+        settings = {
+          main = {
+            control = "overload(control, esc)";
+
+            insert = "S-insert";
+          };
+        };
+      };
+    };
+  };
+}