about summary refs log tree commit diff
path: root/modules/persistence.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/persistence.nix')
-rw-r--r--modules/persistence.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/modules/persistence.nix b/modules/persistence.nix
index 3131d61..22d9be6 100644
--- a/modules/persistence.nix
+++ b/modules/persistence.nix
@@ -17,6 +17,8 @@ in
       '';
     };
 
+    setupSshHostKeys = mkEnableOption "configure persistence for OpenSSH Host keys";
+
     directories = mkOption {
       type = types.listOf types.str;
       default = [ ];
@@ -28,7 +30,7 @@ in
 
     environment.persistence.${cfg.storagePath}.directories = cfg.directories;
 
-    services.openssh.hostKeys = [
+    services.openssh.hostKeys = mkIf cfg.setupSshHostKeys [
       {
         path = "${cfg.storagePath}/ssh/ssh_host_ed25519_key";
         type = "ed25519";