about summary refs log tree commit diff
path: root/nixos/cobalt/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/cobalt/configuration.nix')
-rw-r--r--nixos/cobalt/configuration.nix10
1 files changed, 2 insertions, 8 deletions
diff --git a/nixos/cobalt/configuration.nix b/nixos/cobalt/configuration.nix
index 1850438..a3c77da 100644
--- a/nixos/cobalt/configuration.nix
+++ b/nixos/cobalt/configuration.nix
@@ -1,7 +1,3 @@
-# Edit this configuration file to define what should be installed on
-# your system.  Help is available in the configuration.nix(5) man page
-# and in the NixOS manual (accessible by running ‘nixos-help’).
-
 { config, pkgs, lib, ... }:
 let
   ipv4 = {
@@ -22,7 +18,6 @@ in
 {
   imports =
     [
-      # Include the results of the hardware scan.
       ./hardware-configuration.nix
 
       ./services/acme.nix
@@ -102,7 +97,7 @@ in
   '';
 
 
-  networking.hostName = hostName; # Define your hostname.
+  networking.hostName = hostName;
 
   networking.useDHCP = false;
   networking.interfaces.${networkInterface} = {
@@ -115,14 +110,13 @@ in
 
   networking.firewall.enable = true;
 
-  # Set your time zone.
   time.timeZone = "UTC";
 
   users.users.root.initialHashedPassword = "";
   users.users.root.openssh.authorizedKeys.keys = [ "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIDi7GGOGVj1Y5Sc1EW6zEdrp78dS6hvmS348pqu9dUsB openpgp:0x6BE7BD6F" ];
   services.openssh.enable = true;
   services.openssh.permitRootLogin = "prohibit-password";
-  # mkdir -p /persist/etc/ssh
+
   services.openssh.hostKeys = [
     {
       path = "/persist/ssh/ssh_host_ed25519_key";