about summary refs log tree commit diff
path: root/nixos/configurations/alpha.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/configurations/alpha.nix')
-rw-r--r--nixos/configurations/alpha.nix22
1 files changed, 1 insertions, 21 deletions
diff --git a/nixos/configurations/alpha.nix b/nixos/configurations/alpha.nix
index 252c358..c472317 100644
--- a/nixos/configurations/alpha.nix
+++ b/nixos/configurations/alpha.nix
@@ -4,7 +4,6 @@
   imports = [ ];
 
   security = {
-    acme.acceptTerms = true;
     protectKernelImage = true;
     rtkit.enable = true;
     sudo.wheelNeedsPassword = false;
@@ -15,26 +14,7 @@
     "nmi_watchdog=0"
     "systemd.watchdog-device/dev/watchdog"
   ];
-  boot.kernel.sysctl = {
-    "net.ipv4.conf.default.log_martians" = 1;
-    "net.ipv4.conf.all.log_martians" = 1;
-    "net.ipv4.tcp_mtu_probing" = 1;
-    "net.ipv4.tcp_syncookies" = 1;
-    "net.ipv4.tcp_congestion_control" = "bbr2";
-    "net.ipv4.conf.default.rp_filter" = 1;
-    "net.ipv4.conf.all.rp_filter" = 1;
-    "net.ipv4.conf.all.accept_source_route" = 0;
-    "net.ipv4.conf.all.send_redirects" = 0;
-    "net.ipv4.conf.default.send_redirects" = 0;
-    "net.ipv4.conf.all.accept_redirects" = 0;
-    "net.ipv4.conf.default.accept_redirects" = 0;
-    "net.ipv4.conf.all.secure_redirects" = 0;
-    "net.ipv4.conf.default.secure_redirects" = 0;
-    "net.ipv6.conf.all.accept_source_route" = 0;
-    "net.ipv6.conf.all.accept_redirects" = 0;
-    "net.ipv6.conf.default.accept_redirects" = 0;
-    "net.ipv4.tcp_rfc1337" = 1;
-  };
+
   # GRUB bootloader
   boot.loader.efi.canTouchEfiVariables = true;
   boot.loader.grub = {