about summary refs log tree commit diff
path: root/nixos/haruka/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/haruka/configuration.nix')
-rw-r--r--nixos/haruka/configuration.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/nixos/haruka/configuration.nix b/nixos/haruka/configuration.nix
index eac1cb3..df6e46f 100644
--- a/nixos/haruka/configuration.nix
+++ b/nixos/haruka/configuration.nix
@@ -18,7 +18,9 @@
 
   # Load the intel iGPU driver
   boot.initrd.kernelModules = [ "i915" ];
-  services.xserver.videoDrivers = [ "intel" ];
+  services.xserver.videoDrivers = [ "intel" "displaylink" ];
+
+  nix.allowedUnfree = [ "displaylink" ];
 
   boot.initrd.supportedFilesystems = [ "zfs" ];
   boot.supportedFilesystems = [ "zfs" ];
@@ -228,6 +230,12 @@
     settings.default_session.command = "${pkgs.greetd.tuigreet}/bin/tuigreet -t -c sway";
   };
 
+  environment.sessionVariables = {
+    # wlroots displaylink hack
+    # see home/profiles/gui and `overlays/patches/wlroots-displaylink` for more info
+    WLR_EVDI_RENDER_DEVICE="/dev/dri/card0";
+  };
+
   systemd.extraConfig = "RebootWatchdogSec=5";
 
   fonts = {