{ pkgs, ... }:

{
  config = {
    activeProfiles = [
      "base"
      "gui"
      "browsing"
      "development"
      "communication"
      "multimedia"
      "creative"
      "research"
      "security"
      "gaming"
    ];

    programs.htop.settings.detailed_cpu_time = true;

    sops.defaultSopsFile = ../../secrets/secrets.yaml;
    sops.gnupg.home = "/home/sefidel/.gnupg";

    wayland.windowManager.sway.config.startup = [
      { command = "${pkgs.openrgb}/bin/openrgb --mode static --color ffffff"; }
    ];
  };
}