{ neotheme }:
with neotheme.colors;
{
layer = "bottom";
position = "top";
height = 21;
modules-left = [ "pulseaudio" "custom/seperator" "cpu" "custom/seperator" "memory" ];
modules-center = [ "sway/workspaces" ];
modules-right = [ "clock" ];
modules = {
"sway/workspaces" = {
all-outputs = true;
persistent_workspaces = {
"α" = [ ];
"β" = [ ];
"γ" = [ ];
"δ" = [ ];
"ε" = [ ];
"ζ" = [ ];
"η" = [ ];
"θ" = [ ];
"ι" = [ ];
"κ" = [ ];
};
};
"clock" = {
interval = 10;
format = " {:%A, %b %d %H:%M}";
};
"cpu" = {
interval = 5;
format = " {usage:3}%";
};
"pulseaudio" = {
format = "{icon} {volume}%";
format-muted = "ﱝ Muted";
format-icons.default = [ " " " " " " ];
};
"memory" = {
interval = 5;
format = " {used:0.2f}GiB";
};
"custom/seperator" = {
format = "|";
interval = "once";
tooltip = false;
};
};
}