{ neotheme }:
with neotheme.colors;
{
layer = "bottom";
position = "top";
height = 21;
modules-left = [ "pulseaudio" "custom/seperator" "cpu" "custom/seperator" "memory" ];
modules-center = [ "sway/workspaces" ];
modules-right = [ "clock" ];
"sway/workspaces" = {
all-outputs = true;
disable-scroll = false;
format = "{name}";
persistent_workspaces = {
"1:I" = [ ];
"2:II" = [ ];
"3:III" = [ ];
"4:IV" = [ ];
"5:V" = [ ];
"6:VI" = [ ];
"7:VII" = [ ];
"8:VIII" = [ ];
"9:IX" = [ ];
"10:X" = [ ];
};
};
"clock" = {
interval = 10;
format = " {:%A, %b %d %H:%M}";
};
"cpu" = {
interval = 5;
format = " {usage:3}%";
};
"pulseaudio" = {
format = "{icon} {volume}%";
format-muted = "ﱝ Muted";
format-icons.default = [ " " " " " " ];
};
"memory" = {
interval = 5;
format = " {used:0.2f}GiB";
};
"custom/seperator" = {
format = "|";
interval = "once";
tooltip = false;
};
}