{ config, lib, pkgs, ... }:
let cfg = config.profiles.creative;
in
{
  imports = [
    ../../../modules/nixpkgs.nix
  ];

  options.profiles.creative = {
    enable = lib.mkEnableOption
      "A profile that enables the system to be used for creating multimedia contents.";
  };

  config = lib.mkIf cfg.enable {
    home.packages = with pkgs; [ inkscape krita kooha kdenlive ];
  };
}