{ inputs, config, lib, pkgs, ... }:
let
  cfg = config.profiles.gaming;
in
{
  imports = [ ../../../modules/nixpkgs.nix ];

  options.profiles.gaming = {
    enable = lib.mkEnableOption
      "A profile that enables the system to be used for gaming.";
  };

  config = lib.mkIf cfg.enable {
    home.packages = with inputs.nix-gaming.packages.${pkgs.system}; [
      osu-stable
      osu-lazer-bin
    ];
  };
}