{ neotheme }:
with neotheme.colors;
{
layer = "bottom";
position = "top";
height = 22;
modules-left = [ "pulseaudio" "custom/separator" "cpu" "custom/separator" "memory" "custom/separator" "idle_inhibitor" ];
modules-center = [ "sway/workspaces" ];
modules-right = [ "battery" "custom/separator" "clock" ];
"sway/workspaces" = {
all-outputs = true;
disable-scroll = false;
format = "{name}";
persistent_workspaces = {
"1:I" = [ ];
"2:II" = [ ];
"3:III" = [ ];
"4:IV" = [ ];
"5:V" = [ ];
"6:VI" = [ ];
"7:VII" = [ ];
"8:VIII" = [ ];
"9:IX" = [ ];
"10:X" = [ ];
};
};
"clock" = {
interval = 10;
format = "TIME {:%A, %b %d %H:%M}";
};
"cpu" = {
interval = 5;
format = "CPU {usage:2}%";
};
"pulseaudio" = {
format = "VOL {volume}%";
format-muted = "VOL Muted";
};
"memory" = {
interval = 5;
format = "MEM {used:0.2f}GiB";
};
"battery" = {
format = "BATT {capacity}%";
format-alt = "PWR {power}Wh";
};
"idle_inhibitor" = {
format = "CAFFEINE {status}";
};
"custom/separator" = {
format = "|";
interval = "once";
tooltip = false;
};
}