about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2024-01-24 13:29:27 +0900
committersefidel <contact@sefidel.net>2024-01-24 18:59:54 +0900
commit8e9b074467006c76768efe04cf1fb1ef9d652c67 (patch)
treefad73c7f94a74c77714c260d1fc0a63e2d205b49 /flake.nix
downloadinfra-modules-8e9b074467006c76768efe04cf1fb1ef9d652c67.tar.gz
infra-modules-8e9b074467006c76768efe04cf1fb1ef9d652c67.zip
initial commit HEAD main
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..823a86f
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,37 @@
+{
+  description = "exotic.sh shared system modules";
+
+  inputs = {
+    unstable.url = "github:nixos/nixpkgs/nixos-unstable";
+
+    impermanence.url = "github:nix-community/impermanence";
+
+    authentik-nix.url = "github:nix-community/authentik-nix";
+    authentik-nix.inputs.nixpkgs.follows = "unstable";
+
+    sops-nix.url = "github:Mic92/sops-nix";
+    sops-nix.inputs.nixpkgs.follows = "unstable";
+
+    nixos-mailserver.url = "gitlab:simple-nixos-mailserver/nixos-mailserver";
+    nixos-mailserver.inputs.nixpkgs.follows = "unstable";
+
+    sefidel-web.url = "git+https://git.exotic.sh/pub/sefidel/sefidel-web";
+  };
+
+  outputs = { self, unstable, ... } @ inputs:
+    let
+      inherit (lib.my) mapModulesRec mapModulesRec';
+
+      system = "x86_64-linux";
+
+      pkgs = import unstable { inherit system; };
+
+      lib = unstable.lib.extend
+        (self: super: { my = import ./lib { inherit pkgs inputs; lib = self; }; });
+    in
+    {
+      lib = lib.my;
+
+      nixosModules = mapModulesRec ./modules import;
+    };
+}