about summary refs log tree commit diff
path: root/modules/services/_template.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2024-01-24 13:29:27 +0900
committersefidel <contact@sefidel.net>2024-01-24 18:59:54 +0900
commit8e9b074467006c76768efe04cf1fb1ef9d652c67 (patch)
treefad73c7f94a74c77714c260d1fc0a63e2d205b49 /modules/services/_template.nix
downloadinfra-modules-main.tar.gz
infra-modules-main.zip
initial commit HEAD main
Diffstat (limited to 'modules/services/_template.nix')
-rw-r--r--modules/services/_template.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/modules/services/_template.nix b/modules/services/_template.nix
new file mode 100644
index 0000000..26634a4
--- /dev/null
+++ b/modules/services/_template.nix
@@ -0,0 +1,13 @@
+{ config, lib, ... }:
+
+with lib;
+let
+  cfg = config.modules.services._template;
+in
+{
+  options.modules.services._template = {
+    enable = mkEnableOption "";
+  };
+
+  config = mkIf cfg.enable { };
+}