about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2024-02-20 19:12:10 +0900
committersefidel <contact@sefidel.net>2024-02-20 19:12:46 +0900
commit60b28b4bed95a745ba1050ebc2fb0c8dc6f925f9 (patch)
tree87b7ca5410af5ee06e0003af0aeaa77e4e2f35dc /flake.nix
parent8e119c73d272e31b548f9bc047e88082a93eac07 (diff)
downloadinfra-60b28b4bed95a745ba1050ebc2fb0c8dc6f925f9.tar.gz
infra-60b28b4bed95a745ba1050ebc2fb0c8dc6f925f9.zip
fix(modules/akkoma): fix OAuth login
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 3ef69b4..e9f1a01 100644
--- a/flake.nix
+++ b/flake.nix
@@ -6,6 +6,8 @@
     unstable-small.url = "github:nixos/nixpkgs/nixos-unstable-small";
     nixpkgs-2111.url = "github:nixos/nixpkgs/nixos-21.11";
 
+    nixpkgs-exotic.url = "git+https://git.exotic.sh/nixpkgs-exotic";
+
     colmena.url = "github:zhaofengli/colmena";
     colmena.inputs.nixpkgs.follows = "unstable";
 
@@ -32,7 +34,7 @@
 
       system = "x86_64-linux";
 
-      pkgs = import unstable { inherit system; };
+      pkgs = import unstable { inherit system; overlays = [ inputs.nixpkgs-exotic.overlays.default ]; };
 
       lib = unstable.lib.extend
         (self: super: { my = import ./lib { inherit pkgs inputs; lib = self; }; });