about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2024-03-10 18:08:08 +0900
committersefidel <contact@sefidel.net>2024-03-10 18:35:16 +0900
commit72360a55287f85ef15b039e4991e3b0459f47dd3 (patch)
tree9ce2e420805671fda7dffaee61bf3f63d69c14dc /flake.nix
parent948f33e70ac0e5789607de8d5bf67f8102da79aa (diff)
downloadinfra-72360a55287f85ef15b039e4991e3b0459f47dd3.tar.gz
infra-72360a55287f85ef15b039e4991e3b0459f47dd3.zip
Revert "feat(modules/matrix-homeserver): use synapse v1.102.0 PR"
This reverts commit 7321f5c20fc758da5e6ce3e5ada280dd9865afe7.

The commit was merged upstream.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/flake.nix b/flake.nix
index e106218..e9f1a01 100644
--- a/flake.nix
+++ b/flake.nix
@@ -7,7 +7,6 @@
     nixpkgs-2111.url = "github:nixos/nixpkgs/nixos-21.11";
 
     nixpkgs-exotic.url = "git+https://git.exotic.sh/nixpkgs-exotic";
-    nixpkgs-synapse.url = "github:NickCao/nixpkgs/matrix-synapse";
 
     colmena.url = "github:zhaofengli/colmena";
     colmena.inputs.nixpkgs.follows = "unstable";
@@ -35,13 +34,7 @@
 
       system = "x86_64-linux";
 
-      pkgs = import unstable { inherit system; overlays = [
-        inputs.nixpkgs-exotic.overlays.default
-        (final: prev: {
-          # TODO: https://github.com/NixOS/nixpkgs/pull/293650
-          inherit (inputs.nixpkgs-synapse.legacyPackages.${system}) matrix-synapse;
-        })
-      ]; };
+      pkgs = import unstable { inherit system; overlays = [ inputs.nixpkgs-exotic.overlays.default ]; };
 
       lib = unstable.lib.extend
         (self: super: { my = import ./lib { inherit pkgs inputs; lib = self; }; });