about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2024-02-11 02:11:21 +0900
committersefidel <contact@sefidel.net>2024-02-11 02:15:33 +0900
commitf4d8ab880a58e00af5a7fcda112baa7de2f8f0df (patch)
treea93467f9cdae84f38e00c95a62464709fa222b82 /flake.nix
parent955671dc0751f320d22ca5cfd2b0a2eb60dd8a99 (diff)
downloadinfra-f4d8ab880a58e00af5a7fcda112baa7de2f8f0df.tar.gz
infra-f4d8ab880a58e00af5a7fcda112baa7de2f8f0df.zip
feat(project)!: support nixos-rebuild and hydra
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix20
1 files changed, 12 insertions, 8 deletions
diff --git a/flake.nix b/flake.nix
index c0da437..3ef69b4 100644
--- a/flake.nix
+++ b/flake.nix
@@ -6,6 +6,12 @@
     unstable-small.url = "github:nixos/nixpkgs/nixos-unstable-small";
     nixpkgs-2111.url = "github:nixos/nixpkgs/nixos-21.11";
 
+    colmena.url = "github:zhaofengli/colmena";
+    colmena.inputs.nixpkgs.follows = "unstable";
+
+    flake-compat.url = "github:edolstra/flake-compat";
+    flake-compat.flake = false;
+
     impermanence.url = "github:nix-community/impermanence";
 
     authentik-nix.url = "github:nix-community/authentik-nix";
@@ -36,12 +42,10 @@
 
       nixosModules = mapModulesRec ./modules import;
 
-      colmena = {
-        meta = {
-          nixpkgs = import unstable { inherit system; overlays = [ (import ./overlays) ]; };
-          specialArgs = { inherit lib inputs system; };
-        };
-      }
-      // mapSystems ./systems { };
-    };
+      nixosConfigurations = mapSystems ./systems { };
+
+      colmena = self.lib.mkColmenaFromNixOSConfigurations self.nixosConfigurations;
+
+      hydraJobs = self.lib.mkHydraFromNixOSConfigurations self.nixosConfigurations;
+   };
 }