about summary refs log tree commit diff
path: root/hydra/jobsets.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2024-02-11 02:11:21 +0900
committersefidel <contact@sefidel.net>2024-02-11 02:15:33 +0900
commitf4d8ab880a58e00af5a7fcda112baa7de2f8f0df (patch)
treea93467f9cdae84f38e00c95a62464709fa222b82 /hydra/jobsets.nix
parent955671dc0751f320d22ca5cfd2b0a2eb60dd8a99 (diff)
downloadinfra-f4d8ab880a58e00af5a7fcda112baa7de2f8f0df.tar.gz
infra-f4d8ab880a58e00af5a7fcda112baa7de2f8f0df.zip
feat(project)!: support nixos-rebuild and hydra
Diffstat (limited to 'hydra/jobsets.nix')
-rw-r--r--hydra/jobsets.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/hydra/jobsets.nix b/hydra/jobsets.nix
new file mode 100644
index 0000000..daf1a5a
--- /dev/null
+++ b/hydra/jobsets.nix
@@ -0,0 +1,34 @@
+{ nixpkgs, ... }:
+
+let
+  pkgs = import nixpkgs {};
+
+  jobsets = {
+    main = {
+      enabled = 1;
+      hidden = false;
+      description = "main branch";
+      nixexprinput = "infra";
+      nixexprpath = "hydra/default.nix";
+      checkinterval = 300;
+      schedulingshares = 100;
+      enableemail = false;
+      emailoverride = "";
+      keepnr = 1;
+      inputs = {
+        infra = {
+          type = "git";
+          value = "https://git.exotic.sh/infra main";
+          emailresponsible = false;
+        };
+        nixpkgs = {
+          type = "git";
+          value = "https://github.com/NixOS/nixpkgs.git nixos-unstable";
+          emailresponsible = false;
+        };
+      };
+    };
+  };
+in {
+  jobsets = pkgs.writeText "jobsets.json" (builtins.toJSON jobsets);
+}