about summary refs log tree commit diff
path: root/modules/flakes.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2024-01-24 19:18:11 +0900
committersefidel <contact@sefidel.net>2024-01-24 19:18:11 +0900
commit497c3cd7864fdbcc546408d6d86ebfad37aa9b78 (patch)
tree6cd5bf30b9953156d71192fa96e34a863dda5926 /modules/flakes.nix
parenta1dc1ff8c07155f697a30145168820612b28b6cd (diff)
downloadinfra-modules.tar.gz
infra-modules.zip
wip: try to use infra-modules infra-modules
Diffstat (limited to 'modules/flakes.nix')
-rw-r--r--modules/flakes.nix36
1 files changed, 0 insertions, 36 deletions
diff --git a/modules/flakes.nix b/modules/flakes.nix
deleted file mode 100644
index 4297fda..0000000
--- a/modules/flakes.nix
+++ /dev/null
@@ -1,36 +0,0 @@
-{ config, inputs, pkgs, lib, ... }:
-
-with lib;
-let
-  base = "/etc/nixpkgs/channels";
-  nixpkgsPath = "${base}/nixpkgs";
-  nixpkgsSmallPath = "${base}/nixpkgsSmall";
-  nixpkgs2111Path = "${base}/nixpkgs2111";
-in
-{
-  options.nix.flakes.enable = mkEnableOption "nix flakes";
-
-  config = lib.mkIf config.nix.flakes.enable {
-    nix = {
-      package = pkgs.nixUnstable;
-      experimentalFeatures = "nix-command flakes";
-
-      registry.nixpkgs.flake = inputs.unstable;
-      registry.nixpkgsSmall.flake = inputs.unstable-small;
-      registry.nixpkgs2111.flake = inputs.nixpkgs-2111;
-
-      nixPath = [
-        "nixpkgs=${nixpkgsPath}"
-        "nixpkgsSmall=${nixpkgsSmallPath}"
-        "nixpkgs2111=${nixpkgs2111Path}"
-        "/nix/var/nix/profiles/per-user/root/channels"
-      ];
-    };
-
-    systemd.tmpfiles.rules = [
-      "L+ ${nixpkgsPath}      - - - - ${inputs.unstable}"
-      "L+ ${nixpkgsSmallPath} - - - - ${inputs.unstable-small}"
-      "L+ ${nixpkgs2111Path}  - - - - ${inputs.nixpkgs-2111}"
-    ];
-  };
-}