about summary refs log tree commit diff
path: root/modules/services/git-daemon.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2024-01-24 19:18:11 +0900
committersefidel <contact@sefidel.net>2024-01-24 19:18:11 +0900
commit497c3cd7864fdbcc546408d6d86ebfad37aa9b78 (patch)
tree6cd5bf30b9953156d71192fa96e34a863dda5926 /modules/services/git-daemon.nix
parenta1dc1ff8c07155f697a30145168820612b28b6cd (diff)
downloadinfra-modules.tar.gz
infra-modules.zip
wip: try to use infra-modules infra-modules
Diffstat (limited to 'modules/services/git-daemon.nix')
-rw-r--r--modules/services/git-daemon.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/modules/services/git-daemon.nix b/modules/services/git-daemon.nix
deleted file mode 100644
index 5d027de..0000000
--- a/modules/services/git-daemon.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ config, lib, ... }:
-
-with lib;
-let
-  cfg = config.modules.services.gitDaemon;
-in
-{
-  disabledModules = [
-    "services/networking/git-daemon.nix"
-  ];
-
-  imports = [
-    ../../overlays/git-daemon-module.nix
-  ];
-
-  options.modules.services.gitDaemon = {
-    enable = mkEnableOption "git daemon";
-  };
-
-  config = mkIf cfg.enable {
-    services.gitDaemon = {
-      enable = true;
-      createUserAndGroup = false;
-      basePath = "/var/lib/gitolite/repositories";
-    };
-
-    networking.firewall.allowedTCPPorts = [ 9418 ];
-  };
-}