about summary refs log tree commit diff
path: root/modules/services/soju.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2024-01-24 19:18:11 +0900
committersefidel <contact@sefidel.net>2024-01-24 19:18:11 +0900
commit497c3cd7864fdbcc546408d6d86ebfad37aa9b78 (patch)
tree6cd5bf30b9953156d71192fa96e34a863dda5926 /modules/services/soju.nix
parenta1dc1ff8c07155f697a30145168820612b28b6cd (diff)
downloadinfra-modules.tar.gz
infra-modules.zip
wip: try to use infra-modules infra-modules
Diffstat (limited to 'modules/services/soju.nix')
-rw-r--r--modules/services/soju.nix48
1 files changed, 0 insertions, 48 deletions
diff --git a/modules/services/soju.nix b/modules/services/soju.nix
deleted file mode 100644
index b2f4faf..0000000
--- a/modules/services/soju.nix
+++ /dev/null
@@ -1,48 +0,0 @@
-{ config, lib, ... }:
-
-with lib;
-let
-  cfg = config.modules.services.soju;
-in
-{
-  disabledModules = [
-    "services/networking/soju.nix"
-  ];
-
-  imports = [
-    ../../overlays/soju-module.nix
-  ];
-
-  options.modules.services.soju = {
-    enable = mkEnableOption "soju bouncer";
-
-    hostName = mkOption { type = types.str; default = config.networking.hostName; };
-    port = mkOption { type = types.port; default = 6697; };
-    tls = {
-      enable = mkEnableOption "enable TLS encryption";
-      acmeHost = mkOption { type = types.str; };
-    };
-  };
-
-  config = mkIf cfg.enable {
-    services.soju = {
-      enable = true;
-      extraGroups = [ "acme" ];
-      hostName = cfg.hostName;
-      listen = [ ":${toString cfg.port}" ];
-    } // optionalAttrs cfg.tls.enable {
-      tlsCertificate = "${config.security.acme.certs.${cfg.tls.acmeHost}.directory}/cert.pem";
-      tlsCertificateKey = "${config.security.acme.certs.${cfg.tls.acmeHost}.directory}/key.pem";
-    };
-
-    systemd.services.soju = {
-      after = [ "acme-finished-${cfg.tls.acmeHost}.target" ];
-    };
-
-    networking.firewall.allowedTCPPorts = [ cfg.port ];
-
-    modules.persistence.directories = [
-      "/var/lib/private/soju"
-    ];
-  };
-}