about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..afcdc08
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,10 @@
+{ inputs, lib, ... }:
+with lib;
+with lib.my;
+{
+  imports = [
+    inputs.impermanence.nixosModules.impermanence
+  ] ++ mapModulesRec' (toString ./modules) import;
+
+  networking.useDHCP = mkDefault false;
+}