about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix18
1 files changed, 10 insertions, 8 deletions
diff --git a/default.nix b/default.nix
index 63f1796..f620865 100644
--- a/default.nix
+++ b/default.nix
@@ -1,8 +1,10 @@
-{ inputs, lib, ... }:
-with lib;
-with lib.my;
-{
-  imports = mapModulesRec' (toString ./modules) import;
-
-  networking.useDHCP = mkDefault false;
-}
+(import
+  (
+    let lock = builtins.fromJSON (builtins.readFile ./flake.lock); in
+    fetchTarball {
+      url = lock.nodes.flake-compat.locked.url or "https://github.com/edolstra/flake-compat/archive/${lock.nodes.flake-compat.locked.rev}.tar.gz";
+      sha256 = lock.nodes.flake-compat.locked.narHash;
+    }
+  )
+  { src = ./.; }
+).defaultNix