about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index e9f1a01..e106218 100644
--- a/flake.nix
+++ b/flake.nix
@@ -7,6 +7,7 @@
     nixpkgs-2111.url = "github:nixos/nixpkgs/nixos-21.11";
 
     nixpkgs-exotic.url = "git+https://git.exotic.sh/nixpkgs-exotic";
+    nixpkgs-synapse.url = "github:NickCao/nixpkgs/matrix-synapse";
 
     colmena.url = "github:zhaofengli/colmena";
     colmena.inputs.nixpkgs.follows = "unstable";
@@ -34,7 +35,13 @@
 
       system = "x86_64-linux";
 
-      pkgs = import unstable { inherit system; overlays = [ inputs.nixpkgs-exotic.overlays.default ]; };
+      pkgs = import unstable { inherit system; overlays = [
+        inputs.nixpkgs-exotic.overlays.default
+        (final: prev: {
+          # TODO: https://github.com/NixOS/nixpkgs/pull/293650
+          inherit (inputs.nixpkgs-synapse.legacyPackages.${system}) matrix-synapse;
+        })
+      ]; };
 
       lib = unstable.lib.extend
         (self: super: { my = import ./lib { inherit pkgs inputs; lib = self; }; });