about summary refs log tree commit diff
path: root/lib/misc.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/misc.nix')
-rw-r--r--lib/misc.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/lib/misc.nix b/lib/misc.nix
new file mode 100644
index 0000000..484d0d5
--- /dev/null
+++ b/lib/misc.nix
@@ -0,0 +1,9 @@
+{ pkgs, ... }:
+
+rec {
+  # ifd3f/infra
+  wrapFile = name: path:
+    (pkgs.runCommand name { inherit path; } ''
+      cp -r "$path" "$out"
+    '');
+}