about summary refs log tree commit diff
path: root/modules/cachix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/cachix/default.nix')
-rw-r--r--modules/cachix/default.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/modules/cachix/default.nix b/modules/cachix/default.nix
deleted file mode 100644
index 5222457..0000000
--- a/modules/cachix/default.nix
+++ /dev/null
@@ -1,23 +0,0 @@
-{ config, pkgs, lib, ... }:
-
-with lib;
-let
-  cfg = config.modules.cachix;
-
-  folder = ./caches;
-  toImport = name: value: folder + ("/" + name);
-  filterCaches = key: value: value == "regular" && lib.hasSuffix ".nix" key;
-  imports = lib.mapAttrsToList toImport (lib.filterAttrs filterCaches (builtins.readDir folder));
-in
-{
-  inherit imports;
-
-  options.modules.cachix = {
-    enable = mkEnableOption "cachix";
-  };
-
-  config = mkIf cfg.enable {
-    nix.settings.substituters = [ "https://cache.nixos.org/" ];
-    environment.systemPackages = [ pkgs.cachix ];
-  };
-}