about summary refs log tree commit diff
path: root/modules/services/matrix-homeserver.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/matrix-homeserver.nix')
-rw-r--r--modules/services/matrix-homeserver.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/modules/services/matrix-homeserver.nix b/modules/services/matrix-homeserver.nix
index 36d6dbc..3dc188b 100644
--- a/modules/services/matrix-homeserver.nix
+++ b/modules/services/matrix-homeserver.nix
@@ -20,10 +20,10 @@ in
       shared_secret = mkOption { type = types.str; };
     };
     secrets = {
-      matrix-server-key = mkOption { type = types.str; description = "path to the server key"; };
-      matrix-shared-secret = mkOption { type = types.str; description = "path to the registration shared secret"; };
-      extra-config-path = mkOption { type = types.nullOr types.str; description = "path to the extra configuration file to source"; };
-      sliding-sync-secret = mkOption { type = types.nullOr types.str; description = "path to the sliding sync secret"; };
+      matrix-server-key = mkOption { type = types.path; description = "path to the server key"; };
+      matrix-shared-secret = mkOption { type = types.path; description = "path to the registration shared secret"; };
+      extra-config-path = mkOption { type = types.nullOr types.path; description = "path to the extra configuration file to source"; };
+      sliding-sync-secret = mkOption { type = types.nullOr types.path; description = "path to the sliding sync secret"; };
     };
   };