about summary refs log tree commit diff
path: root/modules/services/matrix-homeserver.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/matrix-homeserver.nix')
-rw-r--r--modules/services/matrix-homeserver.nix18
1 files changed, 9 insertions, 9 deletions
diff --git a/modules/services/matrix-homeserver.nix b/modules/services/matrix-homeserver.nix
index 6687e1d..36d6dbc 100644
--- a/modules/services/matrix-homeserver.nix
+++ b/modules/services/matrix-homeserver.nix
@@ -95,16 +95,16 @@ in
           "turn:${cfg.turn.domain}?transport=tcp"
         ];
       };
+    };
 
-      sliding-sync = {
-        enable = true;
-        createDatabase = true;
-        settings = {
-          SYNCV3_SERVER = "https://${cfg.realHost}";
-          SYNCV3_BINDADDR = "[::1]:${toString slidingSyncPort}";
-        };
-        environmentFile = cfg.secrets.sliding-sync-secret;
+    services.matrix-sliding-sync = {
+      enable = true;
+      createDatabase = true;
+      settings = {
+        SYNCV3_SERVER = "https://${cfg.realHost}";
+        SYNCV3_BINDADDR = "[::1]:${toString slidingSyncPort}";
       };
+      environmentFile = cfg.secrets.sliding-sync-secret;
     };
 
     services.prometheus.scrapeConfigs = [
@@ -182,7 +182,7 @@ in
     services.nginx.virtualHosts.${cfg.slidingSyncHost} = {
       forceSSL = true;
       useACMEHost = cfg.domain;
-      locations."/".proxyPass = "http://${config.services.matrix-synapse.sliding-sync.settings.SYNCV3_BINDADDR}";
+      locations."/".proxyPass = "http://${config.services.matrix-sliding-sync.settings.SYNCV3_BINDADDR}";
     };
 
     networking.firewall.allowedTCPPorts = [ 443 8448 ];