about summary refs log tree commit diff
path: root/modules/services/pubnix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/pubnix.nix')
-rw-r--r--modules/services/pubnix.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/modules/services/pubnix.nix b/modules/services/pubnix.nix
new file mode 100644
index 0000000..dfe3d58
--- /dev/null
+++ b/modules/services/pubnix.nix
@@ -0,0 +1,20 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+let
+  cfg = config.modules.services.pubnix;
+in
+{
+  options.modules.services.pubnix = {
+    enable = mkEnableOption "serve pubnix shell";
+  };
+
+  config = mkIf cfg.enable {
+    nix.gc.automatic = true;
+    nix.gc.dates = "daily";
+
+    environment.systemPackages = with pkgs; [
+      bsd-finger
+    ];
+  };
+}