about summary refs log tree commit diff
path: root/overlays/sliding-sync-module.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/sliding-sync-module.nix')
-rw-r--r--overlays/sliding-sync-module.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/overlays/sliding-sync-module.nix b/overlays/sliding-sync-module.nix
index c9e3f59..8117e2b 100644
--- a/overlays/sliding-sync-module.nix
+++ b/overlays/sliding-sync-module.nix
@@ -57,6 +57,13 @@ in
         If unset does not send OTLP traces.
       '';
     };
+    after = lib.mkOption {
+      type = lib.types.listOf lib.types.str;
+      default = null;
+      description = lib.mdDoc ''
+        The service that should start before the sliding-sync proxy.
+      '';
+    };
   };
 
   config = lib.mkIf cfg.enable {
@@ -64,7 +71,7 @@ in
       description = "MSC3575 Matrix Sliding Sync Proxy";
       after = [
         "network.target"
-      ];
+      ] ++ cfg.after;
       wantedBy = [ "multi-user.target" ];
       serviceConfig = {
         Type = "simple";