about summary refs log tree commit diff
path: root/overlays/sliding-sync.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/sliding-sync.nix')
-rw-r--r--overlays/sliding-sync.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/overlays/sliding-sync.nix b/overlays/sliding-sync.nix
new file mode 100644
index 0000000..50c058d
--- /dev/null
+++ b/overlays/sliding-sync.nix
@@ -0,0 +1,22 @@
+{ lib, buildGoModule, fetchFromGitHub }:
+
+# TODO: needs:
+# - tests
+# - `meta` attribute
+
+buildGoModule rec {
+  pname = "sliding-sync";
+  version = "0.99.1";
+  src = fetchFromGitHub {
+    owner = "matrix-org";
+    repo = "sliding-sync";
+    rev = "v${version}";
+    sha256 = "sha256-g1yMGb8taToEFG6N057yPcdZB855r0f6EwnJ98FIiic=";
+  };
+
+  vendorHash = "sha256-FmibAVjKeJUrMSlhoE7onLoa4EVjQvjDI4oU4PB5LBE=";
+
+  subPackages = [
+    "cmd/syncv3"
+  ];
+}