about summary refs log tree commit diff
path: root/darwin/delta/configuration.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2025-01-19 09:05:06 +1000
committersefidel <contact@sefidel.net>2025-01-19 09:05:06 +1000
commit0ad9ad6711d1623922b42577e6f60d66c1a5a331 (patch)
tree99f1a37f1e770ec892055eb80f420509e5463016 /darwin/delta/configuration.nix
parent73340250f8e141124fd38a12a7412480dcd00a3c (diff)
downloadnixrc-0ad9ad6711d1623922b42577e6f60d66c1a5a331.tar.gz
nixrc-0ad9ad6711d1623922b42577e6f60d66c1a5a331.zip
feat(darwin): configure delta
Diffstat (limited to 'darwin/delta/configuration.nix')
-rw-r--r--darwin/delta/configuration.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/darwin/delta/configuration.nix b/darwin/delta/configuration.nix
new file mode 100644
index 0000000..5ce8eb0
--- /dev/null
+++ b/darwin/delta/configuration.nix
@@ -0,0 +1,18 @@
+{ pkgs, ... }:
+
+{
+  homebrew = {
+    enable = true;
+    brews = [
+      # Thunderbird requires GPGME in 'standard locations'
+      "gpgme"
+    ];
+  };
+
+  # Necessary for using flakes on this system.
+  nix.settings.experimental-features = "nix-command flakes";
+
+  # $ darwin-rebuild changelog
+  system.stateVersion = 5;
+  nixpkgs.hostPlatform = "aarch64-darwin";
+}