about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2022-01-22 22:17:22 +0900
committersefidel <contact@sefidel.net>2022-01-22 22:17:22 +0900
commit220dde08b73ed0091fed2b5b5cefd59708366376 (patch)
treeae5ca3eb0bf264840fa433e34736a331682751c5 /flake.nix
parent059b86f0e04f52b38331ab58b32092ecf6ef616c (diff)
downloadnixrc-220dde08b73ed0091fed2b5b5cefd59708366376.tar.gz
nixrc-220dde08b73ed0091fed2b5b5cefd59708366376.zip
flakes: pin registry and nix path
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 9 insertions, 7 deletions
diff --git a/flake.nix b/flake.nix
index 92ae9d9..940ffb6 100644
--- a/flake.nix
+++ b/flake.nix
@@ -3,30 +3,32 @@
 
   inputs = {
     # Flake inputs
-    nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable-small";
+    unstable.url = "github:nixos/nixpkgs/nixos-unstable";
+    unstable-small.url = "github:nixos/nixpkgs/nixos-unstable-small";
+    nixpkgs-2111.url = "github:nixos/nixpkgs/nixos-21.11";
     master.url = "github:nixos/nixpkgs/master";
 
     home-manager.url = "github:nix-community/home-manager";
-    home-manager.inputs.nixpkgs.follows = "nixpkgs";
+    home-manager.inputs.nixpkgs.follows = "unstable-small";
 
     flake-utils.url = "github:numtide/flake-utils";
-    flake-utils.inputs.nixpkgs.follows = "nixpkgs";
+    flake-utils.inputs.nixpkgs.follows = "unstable-small";
 
     sops-nix.url = "github:Mic92/sops-nix";
-    sops-nix.inputs.nixpkgs.follows = "nixpkgs";
+    sops-nix.inputs.nixpkgs.follows = "unstable-small";
 
     neovim.url = "github:neovim/neovim?dir=contrib";
-    neovim.inputs.nixpkgs.follows = "nixpkgs";
+    neovim.inputs.nixpkgs.follows = "unstable-small";
 
     # https://github.com/NixOS/nix/pull/5342
     chaotic-nixpkgs.url = "git+https://git.sr.ht/~boppy/chaotic-nixpkgs?ref=main";
-    chaotic-nixpkgs.inputs.nixpkgs.follows = "nixpkgs";
+    chaotic-nixpkgs.inputs.nixpkgs.follows = "unstable-small";
 
     phocus = { url = "git+https://git.sr.ht/~boppy/phocus"; flake = false; };
     wallpapers = { url = "git+https://git.sr.ht/~boppy/wall?ref=main"; flake = false; };
   };
 
-  outputs = { self, nixpkgs, flake-utils, sops-nix, ... } @ inputs:
+  outputs = { self, ... } @ inputs:
     {
 
       nixosConfigurations = import ./nixos inputs;