about summary refs log tree commit diff
path: root/home/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2023-06-02 22:11:08 +0900
committersefidel <contact@sefidel.net>2023-06-02 22:11:08 +0900
commit1642de788ccac8098d944066184a0c71b7a8e537 (patch)
treeeb6ddd182008486a6ac6234b997113d346f9dcc0 /home/default.nix
parentfab665812fa1d507fbfb0fc143afe873163b7d36 (diff)
downloadnixrc-1642de788ccac8098d944066184a0c71b7a8e537.tar.gz
nixrc-1642de788ccac8098d944066184a0c71b7a8e537.zip
fix(darwin/kompakt-darwin): fixup
Diffstat (limited to 'home/default.nix')
-rw-r--r--home/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/home/default.nix b/home/default.nix
index 9c9e324..b338929 100644
--- a/home/default.nix
+++ b/home/default.nix
@@ -41,4 +41,25 @@
 
     version = "23.05";
   };
+
+  "sefidel@kompakt-darwin" = self.lib.mkHome {
+    username = "sefidel";
+    hostname = "kompakt-darwin";
+    pkgs = import unstable { system = "aarch64-darwin"; overlays = with inputs; [ rust.overlays.default (import ../overlays/neovim.nix) neovim.overlay ]; };
+
+    extraModules = [
+      ./profiles/populate.nix
+      ./profiles/base-darwin
+      ./profiles/browsing
+      ./profiles/development
+      ./profiles/communication
+      ./profiles/multimedia
+      ./profiles/research
+      ./profiles/fonts
+
+      inputs.sops-nix.homeManagerModules.sops
+    ];
+
+    version = "23.05";
+  };
 }