about summary refs log tree commit diff
path: root/home/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2022-09-09 17:49:03 +0900
committersefidel <contact@sefidel.net>2022-09-09 21:32:31 +0900
commit9e6145c031b47fc37398b80dec1b4dfc0cfb5183 (patch)
treef27e3c50a0c25223931e7057616e456432007de9 /home/default.nix
parent9e311725d4f6c68284e3999c01735ebe3665a14d (diff)
downloadnixrc-9e6145c031b47fc37398b80dec1b4dfc0cfb5183.tar.gz
nixrc-9e6145c031b47fc37398b80dec1b4dfc0cfb5183.zip
milestone: darwin!
feat(darwin/kompakt)!: support darwin

chore: reformat

feat(home/o32): manage neovim

feat(home/development): fix haskell lsp version mismatch

feat(darwin/*): stabilise
Diffstat (limited to 'home/default.nix')
-rw-r--r--home/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/home/default.nix b/home/default.nix
index f8ce8fe..5c7f857 100644
--- a/home/default.nix
+++ b/home/default.nix
@@ -18,4 +18,19 @@
 
     version = "22.05";
   };
+
+  "o32@kompakt" = self.lib.mkHome {
+    username = "o32";
+    hostname = "kompakt";
+    pkgs = import unstable { system = "aarch64-darwin"; overlays = with inputs; [ rust.overlays.default (import ../darwin/darwin-x86.nix { inherit unstable; }) ]; };
+
+    extraModules = [
+      ./profiles/populate.nix
+      ./profiles/base-darwin
+      ./profiles/development
+      ./profiles/messaging
+    ];
+
+    version = "22.05";
+  };
 }