about summary refs log tree commit diff
path: root/home/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2023-11-12 20:37:40 +0900
committersefidel <contact@sefidel.net>2023-11-12 20:37:40 +0900
commita0163ad377303fa746d023726230a8b94173ceaf (patch)
treea5bb8dd02a9233c0c55033b9577765deb9a9b759 /home/default.nix
parent3db03e8d0da1d27376e32183d02bdca38be2d809 (diff)
downloadnixrc-a0163ad377303fa746d023726230a8b94173ceaf.tar.gz
nixrc-a0163ad377303fa746d023726230a8b94173ceaf.zip
feat(flake): neovim -> neovim-nightly
This commit replaces neovim with nix-community's neovim-nightly overlay
flake, in an effort to reduce the frequency of dependency build errors.
Diffstat (limited to 'home/default.nix')
-rw-r--r--home/default.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/home/default.nix b/home/default.nix
index 2f17aa8..6d51ce5 100644
--- a/home/default.nix
+++ b/home/default.nix
@@ -1,11 +1,10 @@
 { self, unstable, ... } @ inputs:
 
-# TODO See: https://github.com/neovim/neovim/pull/21711
 {
   "sefidel@alpha" = self.lib.mkHome {
     username = "sefidel";
     hostname = "alpha";
-    pkgs = import unstable { system = "x86_64-linux"; overlays = with inputs; [ rust.overlays.default neovim.overlay helix.overlays.default ]; };
+    pkgs = import unstable { system = "x86_64-linux"; overlays = with inputs; [ rust.overlays.default neovim-nightly.overlay helix.overlays.default ]; };
 
     extraModules = [
       ./profiles/populate.nix
@@ -29,7 +28,7 @@
   "sefidel@haruka" = self.lib.mkHome {
     username = "sefidel";
     hostname = "haruka";
-    pkgs = import unstable { system = "x86_64-linux"; overlays = with inputs; [ rust.overlays.default neovim.overlay helix.overlays.default ]; };
+    pkgs = import unstable { system = "x86_64-linux"; overlays = with inputs; [ rust.overlays.default neovim-nightly.overlay helix.overlays.default ]; };
 
     extraModules = [
       ./profiles/populate.nix
@@ -53,7 +52,7 @@
   "sefidel@cobalt" = self.lib.mkHome {
     username = "sefidel";
     hostname = "cobalt";
-    pkgs = import unstable { system = "x86_64-linux"; overlays = with inputs; [ rust.overlays.default neovim.overlay ]; };
+    pkgs = import unstable { system = "x86_64-linux"; overlays = with inputs; [ rust.overlays.default neovim-nightly.overlay ]; };
 
     extraModules = [
       ./profiles/populate.nix