about summary refs log tree commit diff
path: root/home/default.nix
diff options
context:
space:
mode:
authorsefidel <contact@sefidel.net>2023-03-05 02:31:39 +0900
committersefidel <contact@sefidel.net>2023-03-05 02:31:39 +0900
commitc580225be681c9953bc78bb53f4144a774440a5e (patch)
tree69f39e9c5bf84c0ca8d785ed6852a9a88eeecde4 /home/default.nix
parent73e80160be0869d79bd8dda17899543732caf996 (diff)
downloadnixrc-c580225be681c9953bc78bb53f4144a774440a5e.tar.gz
nixrc-c580225be681c9953bc78bb53f4144a774440a5e.zip
fix(home/base): temporary fix for neovim master builds
Diffstat (limited to 'home/default.nix')
-rw-r--r--home/default.nix14
1 files changed, 10 insertions, 4 deletions
diff --git a/home/default.nix b/home/default.nix
index 567883b..3004cb3 100644
--- a/home/default.nix
+++ b/home/default.nix
@@ -1,12 +1,18 @@
-{ self, unstable, ... } @ inputs:
+{ self, unstable, nixpkgs-neovim-fix, ... } @ inputs:
 
-{
+let
   # TODO See: https://github.com/neovim/neovim/pull/21711
   # TODO See: https://github.com/NixOS/nixpkgs/pull/214231
+  neovim-fix = self: super: {
+    inherit (nixpkgs-neovim-fix.legacyPackages.${super.system})
+      neovim neovim-unwrapped;
+  };
+in
+{
   "sefidel@alpha" = self.lib.mkHome {
     username = "sefidel";
     hostname = "alpha";
-    pkgs = import unstable { system = "x86_64-linux"; overlays = with inputs; [ rust.overlays.default /*neovim.overlay*/ ]; };
+    pkgs = import unstable { system = "x86_64-linux"; overlays = with inputs; [ rust.overlays.default neovim-fix neovim.overlay ]; };
 
     extraModules = [
       ./profiles/populate.nix
@@ -27,7 +33,7 @@
   "sefidel@kompakt" = self.lib.mkHome {
     username = "sefidel";
     hostname = "kompakt";
-    pkgs = import unstable { system = "aarch64-linux"; overlays = with inputs; [ rust.overlays.default /*neovim.overlay*/ ]; };
+    pkgs = import unstable { system = "aarch64-linux"; overlays = with inputs; [ rust.overlays.default neovim-fix neovim.overlay ]; };
 
     extraModules = [
       ./profiles/populate.nix